Virus and threat protection features

Norton AntiVirus provides comprehensive virus prevention, threat detection, and repair software for your computer. It automatically detects and repairs known viruses. Norton AntiVirus detects viruses and other potential risks in instant messenger attachments as well as in email messages, Internet downloads, and other files. Easy updating of the virus definitions over the Internet keeps Norton AntiVirus prepared for the latest threats. Norton AntiVirus also scans files inside of compressed files.

Norton AntiVirus continually monitors your computer and protects it from known and unknown threats using the following features:

Auto-Protect

  • Loads into memory when Windows starts, providing constant protection while you work.

  • Checks for viruses and other security threats every time that you use software programs on your computer, insert floppy disks or other removable media, access the Internet, or use document files that you receive or create.

  • Monitors your computer for any unusual symptoms that may indicate an active threat.

    Responding to Auto-Protect alertsResponding to Auto-Protect alerts

Automatic LiveUpdate

Notifies you of program updates and downloads virus definitions updates automatically.

What gets updated

Compressed file protection

Detects viruses, spyware, and other security risks inside of compressed files during manual scans. You can also configure Auto-Protect options to scan within compressed files.

Email protection

Protects incoming and outgoing email messages, preventing your computer and other computers from infection.

Instant messenger protection

Scans for and detects viruses in instant messenger attachments.

Bloodhound technology

Detects new and unknown viruses by analyzing an executable file’s structure, behavior, and other attributes such as programming logic, computer instructions, and any data that is contained in the file.

Password protection

Protects Norton AntiVirus options from unauthorized changes.

Norton QuickScan

Checks for infections that have processes running in memory and infections that are referenced by start-up folders and files.

Automatically runs once LiveUpdate updates your computer with program updates and virus definitions.