Norton Internet Worm Protection features

Norton Internet Worm Protection features copyright 2004 Symantec

Internet Worm Protection prevents incoming network worms and other Internet threats from attacking your computer. A worm is similar to a virus, but is a self-contained program that can replicate itself over a computer network. Internet Worm Protection can detect a worm on the network before it copies itself onto your computer.

Internet Worm Protection uses the following methods to detect and handle incoming worms and Internet attacks:

Port blocking | Blocks incoming worm activity.
Trojan horse detection | Detects if a connection is being attempted on a port that is commonly used by Trojan horse applications. If the connection matches a Trojan horse rule, Internet Worm Protection issues an alert. Internet Worm Protection Alerts
Auto blocking | Blocks repeated Internet attacks. When Internet Worm Protection detects an attack, it automatically blocks any further communication from the attacker's computer. The attacker's IP address is blocked for 30 minutes. Internet Worm Protection lets you manually remove an attacker's IP address from the list at any time. Customize AutoBlock
General rules | Internet Worm Protection uses a set of rules to monitor and handle all traffic and applications on the network. These rules control how Internet Worm Protection guards your computer from malicious incoming traffic, programs, and Trojan horses. Internet Worm Protection should provide adequate protection for most users. If the default protection is not appropriate, you can add, modify, or remove rules in the rules wizard. Customize General Rules
Traffic analysis | Monitors network traffic for malicious activity. If such activity is detected, Internet Worm Protection blocks the traffic, logs the event, and issues an alert.
Exploit detection | Prevents another computer from exploiting bugs in your computer's software. Worms use these bugs to transfer infected files onto your computer.
Threat level | Scans an application for known viruses, and determines whether a program is malicious.

More Information


CPDGlossary.html

CPDGlossary.html copyright 2004 Symantec