Activating Online Backup

Activating your Norton 360 Online Backup requires that you have already established a Norton Account. If you have not yet established a Norton Account, you will be prompted to do so.


Back Up Now

Backing up files immediately is a simple process. Even if your scheduled backup is set, you can still back up your files right now so that you are secure in knowing any work you had just accomplished is safe.

If you have many files to back up, the first backup could possibly take several hours or even several days depending on the speed of your Internet connection and the size of your backup. If a large backup is interrupted, it will resume where it left off, and continue until it completes the backup. This activity takes place when you are not using your PC, so you can continue your normal computing activities. Subsequent backups, which affect only updated or changed files, will take much less time.