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View products that this article applies to.

Problem description The Recycle Bin does not appear on the desktop in
Windows Vista or in Windows XP. Therefore, you
cannot use the Recycle Bin to do such tasks as restoring a file that was deleted. This article will help

you make the Recycle Bin work again.

To have us fix this problem for you, go to the "Fix it for me" section. If you would rather fix this

problem yourself, go to the "Let me fix it myself" section.

 Back to the top

To fix this problem automatically, click the Fix this problem link. Then click Run in the File

Download dialog box, and follow the steps in this wizard.

Microsoft®
L] [ ]
Fixit
Fix this problem

Microsoft Fix it 50210

Note This wizard may be in English only; however, the automatic fix also works for other language

versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash

drive or to a CD, and then you can run it on the computer that has the problem.

Next steps

Check whether the problem is fixed. If the problem is fixed, you are finished with this article. If the
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Let me fix it myself

problem is not fixed, you can try the procedure in the Workaround section.

“ Back to the top

% Back to the top

To fix this issue in Windows Vista, follow these steps:

1. Click Start, and then click Control Panel.
2. Click Appearance and Personalization, click Personalization, and then click Change
desktop icons.

3. Click to select the Recycle Bin check box, and then click OK.

Next steps

Check whether the problem is fixed. If the problem is fixed, you are finished with this article. If the

problem is not fixed, you can try the procedure in the "Workaround" section.

“ Back to the top

To fix this issue in Windows XP, use one of the following methods:

Method 1: Use the program that removed the Recycle Bin to restore the Recycle Bin

Note If you used the TweakUI program to hide the Recycle Bin, follow these steps to restore the

Recycle Bin to the desktop. If you did not use the TweakUI program, see Method 2 or Method 3.

Important This section, method, or task contains steps that tell you how to modify the registry.
However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure
that you follow these steps carefully. For added protection, back up the registry before you modify it.
Then, you can restore the registry if a problem occurs. For more information about how to back up
and restore the registry, click the following article number to view the article in the Microsoft
Knowledge Base:

322756 How to back up and restore the registry in Windows

1. Click Start, click Run, type regedit, and then click OK.
2. If you are using the standard Windows XP Start menu

a. Locate the following registry key:
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HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer

\HideDesktoplcons\NewStartPanel

c. In the right pane, right-click the following registry DWORD value, and then click Modify:

{645FF040-5081-101B-9F08-00AAO02F954E}

d. In the Value data box, type O, and then click OK. (The TweakUI utility sets this value to 1 to

hide the Recycle Bin icon.)

If you are using the classic Windows XP Start menu

a. Locate the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer

\HideDesktoplcons\ClassicStartMenu

b. In the right pane, right-click the following registry DWORD value, and then click Modify:

{645FF040-5081-101B-9F08-00AAO02F954E}

c. In the Value data box, type O, and then click OK. (The TweakUI utility sets this value to 1 to

hide the Recycle Bin icon.)

. Click Exit to exit Registry Editor.

Next steps

. Check whether the problem is fixed. If the problem is fixed, you are finished with this article.

If the problem is not fixed, you can try the procedure in the "Workaround" section.

Method 2: Edit the registry to restore the Recycle Bin

Note If the system administrator used a Group Policy setting to hide the Recycle Bin (or "All Icons")

on the Desktop, see Method 3.

Important This section, method, or task contains steps that tell you how to modify the registry.
However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure
that you follow these steps carefully. For added protection, back up the registry before you modify it.
Then, you can restore the registry if a problem occurs. For more information about how to back up

and restore the registry, click the following article number to view the article in the Microsoft
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Knowledge Base:

322756 How to back up and restore the registry in Windows

To edit the registry to make the Recycle Bin icon reappear on the desktop, follow these steps:

1. Click Start, and then click Run.

2. In the Open box, type regedit, and then click OK.

3. Locate the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop

\NameSpace

4. Right-click the registry key that you located in step 3, point to New, and then click Key.

5. Type {645FF040-5081-101B-9F08-00AA002F954E}, and then press ENTER.

6. Click the new {645FF040-5081-101B-9F08-00AA002F954E} key that you created in
step 5.

7. In the right pane, double-click the (Default) entry.

8. In the Edit String dialog box, type Recycle Bin in the Value data box, and then click OK.

9. Close Registry Editor.

Next steps

Check whether the problem is fixed. If the problem is fixed, you are finished with this article. If the

problem is not fixed, you can try the procedure in the "Workaround" section.

Method 3: Use the Group Policy Object Editor to restore the Recycle Bin

If the system administrator used a Group Policy setting to hide the Recycle Bin or "All Icons" on the
Desktop, you may have to contact the system administrator to restore the Recycle Bin icon. The
system administrator can either use the Group Policy Object Editor (GPEDIT.msc) or manually
remove the registry information (that was created through the Group Policy Object Editor) for the

Recycle Bin to restore the Recycle Bin icon to the Desktop.

Note The following procedures works only on Windows XP Professional. If your system is not

Windows XP Professional, you can try the procedure in the "Workaround" section.

Important This section, method, or task contains steps that tell you how to modify the registry.
However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure

that you follow these steps carefully. For added protection, back up the registry before you modify it.
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Then, you can restore the registry if a problem occurs. For more information about how to back up
and restore the registry, click the following article number to view the article in the Microsoft
Knowledge Base:

322756 How to back up and restore the registry in Windows

. To use the Group Policy Object Editor to restore the Recycle Bin:
1. Click Start, click Run, type GPEDIT.MSC in the Open box, and then click OK.
2. Under User Configuration, click Administrative Templates, and then double-click
Desktop.
3. Double-click Remove Recycle Bin icon from the desktop.
4. Click the Setting tab, click Not Configured, and then click OK.
. To use Registry Editor to restore the Recycle Bin:
1. Click Start, click Run, type regedit, and then click OK.
2. Locate the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

\NonEnum

. Click the registry key that you located in step 3, and then in the right pane, click the following
registry DWORD value:

{645FF040-5081-101B-9F08-00AA002F954E}
. On the Edit menu, click Delete, and then click Yes.

. Close Registry Editor.

Next steps

Check whether the problem is fixed. If the problem is fixed, you are finished with this article. If the

problem is not fixed, you can try the procedure in the "Workaround" section.

“* Back to the top

Workaround If you cannot restore the Recycle Bin by using the resolutions that are listed in this article,

work around this issue by creating a shortcut to the Recycle Bin:

1. Click Start, and then click My Computer.

2. On the Tools menu, click Folder Options.
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3. Click the View tab, and then click to clear the Hide protected operating system files
(Recommended) check box.

4. Click Yes when you receive the warning message, and then click OK to close the Folder
Options dialog box.

5. Click Folders on the toolbar.

Note If Folders is not visible on the toolbar, point to Toolbars on the View menu, and then
click Standard Buttons.

6. In the left navigation pane, under Folders, locate the Recycle Bin folder, and then drag the
Recycle Bin folder to the desktop.

7. On the Tools menu, click Folder Options.

8. Click the View tab, and then click to select the Hide protected operating system files

(Recommended) check box. Click OK.

Note This procedure does not re-create the original icon. However, this procedure restores most of

the features of the Recycle Bin. This includes the following:

. Delete a file by dragging it to the Recycle Bin icon on your Desktop.

. Retrieve a file that you deleted by double-clicking the Recycle Bin icon on your Desktop,
right-clicking the file that you want to retrieve, and then clicking Restore.

. Empty the Recycle Bin by right-clicking the Recycle Bin icon on your Desktop, and then

clicking Empty Recycle Bin.

Note When you use these step to work around this problem, you cannot right-click the Recycle Bin
shortcut to access the Recycle Bin Properties. To set properties for the Recycle Bin, follow these

steps:

1. Double-click the Recycle Bin shortcut on the Desktop. The Recycle Bin folder opens.
2. In the upper-left corner of the Recycle Bin folder, right-click the Recycle Bin icon, and then

click Properties.

If this procedure did not fix the problem, you can contact support.

“* Back to the top
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Cause Several issues could cause this problem:

. A third-party program was used to hide the Recycle Bin.
. The TweakUI program was used to hide the Recycle Bin.
. The registry information for the Recycle Bin was deleted.

. A Group Policy setting was used to hide the Recycle Bin.

Note Windows XP Home Edition does not support Group Policy.

“+ Back to the top

REFERENCES For help with common system maintenance tasks in Windows Vista, visit the following
Microsoft Web page:

Fix problems with common system maintenance tasks

“ Back to the top

APPLIES TO

. Microsoft Windows XP Home Edition

. Microsoft Windows XP Professional

. Windows Vista Enterprise

. Windows Vista Home Basic

. Windows Vista Home Premium

. Windows Vista Starter

. Windows Vista Ultimate

. Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
. Microsoft Windows Server 2003 R2 Datacenter x64 Edition

. Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
. Microsoft Windows Server 2003 R2 Enterprise x64 Edition

. Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
. Microsoft Windows Server 2003 R2 Standard x64 Edition

. Microsoft Windows Server 2003 Scalable Networking Pack

. Microsoft Windows Server 2003 Service Pack 1
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. Microsoft Windows Server 2003 Service Pack 2

. Microsoft Windows Server 2003, Web Edition

. Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
. Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
. Microsoft Windows Server 2003, Datacenter x64 Edition

. Microsoft Windows Server 2003, Enterprise x64 Edition

. Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
. Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
. Microsoft Windows Server 2003, Standard x64 Edition

. Microsoft Windows Server 2003, Standard Edition (32-bit x86)

. Windows Server 2008 Datacenter without Hyper-V

. Windows Server 2008 Enterprise without Hyper-V

. Windows Server 2008 for Itanium-Based Systems

. Windows Server 2008 R2 Beta

. Windows Server 2008 R2 Datacenter

. Windows Server 2008 R2 Datacenter without Hyper-V

. Windows Server 2008 R2 Enterprise

. Windows Server 2008 R2 Enterprise without Hyper-V

. Windows Server 2008 R2 Standard

. Windows Server 2008 R2 Standard without Hyper-V

. Windows Server 2008 Service Pack 2

. Windows Server 2008 Standard without Hyper-V

. Windows Server 2008 Datacenter

. Windows Server 2008 Enterprise

. Windows Server 2008 Standard
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Get Help Now
! J Contact a support professional by E-mail, Online, or Phone
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